Post

9 followers Follow
5
Avatar

\ 3D Model Troubleshooting

3D models don't show up on my device. Why?

3D models are enabled for all iOS devices with at least 512M RAM. Therefore 3D models work for iPhone4 and above, iPad 2+, iPad Mini, iPod Touch 5th Gen+.

On Android, 3D models are enabled by default, but switched off for a few devices we know to have problems with 3D drivers. 

 

Uploading 3D models to Aurasma Studio

Please check our 3D Model Guidelines

Troubleshooting:

You may run into problems with creating the model .tar archive and uploading it. To check you are doing things the right way, try uploading our example model. Note that you will need to extract this archive and find the file "aurasmabox.tar". You can also extract/open this tar file to examine the contents to get an idea of what to put in your model tar files.

AurasmaBox Model Example

Here are some common error messages, with what they mean and how to fix the problem:

Status:    500

Message:    Invalid archive contents

It's likely you have tarred the model directory. You need to tar the files in the directory, without tarring the directory.

If you're using 7zip to create the tar file, go into the directory that contains your model files (.dae, thumbnail.png, any textures), select all the files, right click -> 7zip -> "add to archive", then make sure "archive format" is Tar and click "OK".

Status:    500

Message:    Unable to locate thumbnail

Please check you have included the model thumbnail image and called it "thumbnail.png" - check you have spelled thumbnail correctly!

Status:    500

Message:   Could not extract valid augmentation type from file: application/octet-stream mymodel.7z

It looks like you're trying to upload a 7z archive. You should upload a tar archive. You can make a tar using 7zip, but by default, 7zip will make 7z archives.

Select all your model files, then right click, 7zip, add to archive, and select tar.

 

Some of the files within the archive had errors:

   - Could not extract valid augmentation type from file: aurasmabox.dae

The remaining 2 files were processed successfully.

It look like you're trying to upload the model .tar using "bulk add". Bulk upload is for uploading multiple overlays.

Individual overlays, such as a single model, can be uploaded using just "add". This is probably what you want to do.

Note that you can use "bulk add" to upload models, by putting your model .tar file inside another tar file. The reason for what you saw is that if you use bulk add with a model .tar (without another tar file containing it), Developer Studio will think you want to upload all the files as separate overlays (rather than as part of a model). It accepts the images but a .dae on its own is not a valid overlay.

Models not showing correctly on device

Model is invisible when viewed on my phone/tablet.

Sometimes .dae files have transparency values "the wrong way around". Aurasma is set up to default to 0.0 = fully transparent to 1.0 = fully opaque for transparency. You may be able to generate files in this format by checking the settings in your exporter. If this is your problem , and if your object is fully opaque, you may be able to fix this simply by find and replace the dae in a text editor -

replace

sid="transparency">0.000000

with

sid="transparency">1.000000

Model is black when viewed on my phone/tablet. ( but looks OK in the 3D viewer in Aurasma Studio )

This is probably because your model is unlit. You need to add lights to your scene.

Aurasma Tech Team

Please sign in to leave a comment.

6 comments

0
Avatar

It sure would be helpful to see a simple and a complex tutorial video that shows someone making a 3D model, using the Maya or Max software, showing all the steps involved. That would remove all the mystery of the process and allow many more people to start creating 3D content. Same applies to video content and any tricks that can be accomplished there.

Mark Burginger 0 votes
0
Avatar

"Model is black when viewed on my phone/tablet..."

Note that I've seen this also occur when the 3D Model is using non power-of-two textures. Its best to use the textures sizes, as recommended in the 3D Model Guidelines.

John Bradley 0 votes
0
Avatar

I've just been uploading 3d models and, when I'm not looking the trigger image from a frontal view, the 3d disappears. Is there a way to avoid this and to move around the 3d object more freely?

 

Thank you for your attention

Pau MF 0 votes
0
Avatar

"Model is black when viewed on my phone/tablet..."

May anyone help me~ I have a problem of 3D model's lights

I used MAYA 2012 and OpenCollada to export model, and follow the setting with this link : http://www.aurasma.com/wp-content/uploads/Aurasma-3D-Guidelines.pdf

When I uploaded to Aurasma Studio, the model is black.

This is my file : https://drive.google.com/folderview?id=0B0qfgYrPSLYrNUF3dHVyMTFxSnc&usp=sharing

Thanks a lot~

Song Song An 0 votes
0
Avatar

Hi,

I'm trying to do a animated 3d model. My model maker has tried following the 3d guidelines set, but I'm still getting a error on upload (below). We have tried a simple box model to see if that works and I still keep getting the error. Can anybody let me know where we're going wrong? I've attached the animated version and cubed helicopter test we did.

I'm not getting any help from Aurasma (support request sent at the beginning of December) as I'm not a 'paying partner'.

Thanks in advance.

Status:    500

Message:    Could not validate augmentation: Cannot resolve texture: #ID5

Date/time:    Mon Dec 29 2014 10:43:28 +0000

Incident ID:    ntl-37-03.1418922504311

 

Elroy Blackwood 0 votes