Follow

iOS8 and Aurasma: Everything You Need To Know

iOS8 For Aurasma Developers

The release of iOS8 is a great opportunity for Aurasma to expand its horizons and push our development further. Our development team has been preparing for this release in order to ensure the Aurasma SDK is ready to comply with all that iOS8 has to offer. Please take a moment to read the information below, as it will guide you to the appropriate Aurasma SDK version for your development environment.

 

My app is already available for download in the App Store:

Good news!  These apps will continue to work when users upgrade to iOS8!  Previously released apps, both skinned and embedded, that are running Aurasma 3.0+ will continue to work without any immediate action on your part.

So what do I need to do now?

Upgrading the Aurasma SDK is not necessary at this time, however, your developer environment will dictate which version of Aurasma we’d recommend using.

I’m using xCode 5:

If you are running xCode5, feel free to use any Aurasma SDK version between v3.0 and v3.3.1. 

I’m using xCode 6:

If you are running xCode 6, you will need to start using Aurasma SDK v3.4.0.

 

 

What does the latest Aurasma SDK offer? (v3.4.0 and higher)

Our newest release of the Aurasma SDK v3.4.0 is designed for developers who are running Xcode 6 and wish to target app users running both iOS7 and iOS8.  Aurasma SDK v3.4.0 drops support for devices running iOS6.

If you are running Xcode 6 you must run Aurasma SDK v3.4.0 or higher.

 

I haven’t updated since Aurasma’s 2.0 code.

The Aurasma team strongly recommends you update these apps to our 3.0+ code to ensure an optimal user-experience.

So what do I need to do now?

I’m using xCode 5:

If you are running xCode5, feel free to use any Aurasma SDK version between v3.0 and v3.3.1.

I’m using xCode 6:

If you are running xCode 6, you will need to start using Aurasma SDK v3.4.0.

 

To submit questions or to have a conversation about your upgrade, please email support@aurasma.zenesk.com.

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk